Performancing Metrics

How to Install VLC in Fedora 20 / 19 / 18

VLC is a free and open source cross-platform multimedia player, which plays most of the multimedia files (MKV, AVI, MP4, etc.,). No codec packs needed to be installed, VLC is simple and powerfull multimedia player works on various Operating System Linux, Mac and Windows.

vlc

To Install VLC on Fedora 20 / 19 / 18 / 17 / 16 / 15

First install the rpmfusion free and non-free release noarch.rpm in your system. To install run the following command in terminal and type the password for the root, when prompted.

su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

Then run the following command in terminal and type the password for the user, when prompted.

sudo yum install vlc

Thats it. This method works on fedora 11 and above.  Enjoy watching movies on vlc!!!!

Key Words:

vlc fedora 20                    fedora 20 vlc

install vlc fedora 20           fedora 20 install vlc

Related Posts Plugin for WordPress, Blogger...

  • Chirag

    Thanx very much Manivannan….
    i m new user of fedora….and was trying to play mp3 files…..
    ur post provided me the solution…

  • Asif Nazir

    Thank you Manivannan . I am new to Fedora and vlc seem not installing . I really appriciate you help .

    bahut bahut shukriya

  • jimothy508

    I couldn’t get VLC to install, I keep getting these as error msgs

    http://linux.dropbox.com/fedora/16/repodata/repomd.xml: [Errno 14] HTTP Error 404 – Not Found : http://linux.dropbox.com/fedora/16/repodata/repomd.xml
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: Dropbox. Please verify its path and try again

    • http://www.howopensource.com Manivannan

      Hi Jimothy,

      This error is not related to vlc, you can ignore it. Try installing the vlc.

  • EddieBear

    TYVM, Manivannan! I searched for a solution for this for a long time. It worked smoothly and perfectly under Fedora 15 x86_64. The only thing I did differently was su to root in terminal beforehand; didn’t need further su nor sudo commands. VLC is a must-have, as far as I’m concerned. You are my hero!

  • kriss

    a great help. Thanks a million

  • manan

    very useful information, appreciate it……………..

  • Joseph

    It is taking very much time to retreive….. please check any other link

    • ASIF

      its workng !!!!!!!!!!!!

  • ilusaud

    I m a beginner in this os,,,,& for vlc installation it is showing incorrect password,,…

  • Govella

    I followed your steps but I get the following message, “mshamumg is not in the sudoers file. This incident will be reported.” what does this mean and what can I do to solve this?

  • Govella

    …and by the way, mshamumg was my username. thanks.

    • http://www.howopensource.com Manivannan

      Hi Govella,

      Login as root in terminal then try again.

  • nandy nandha

    dude, when typed those commands my terminal says:
    “nandha is not on the sudoers list”
    “this will be reported”
    what i have to do now?

    • http://www.howopensource.com Manivannan

      Hi Nandy,

      Login as root in terminal then try again or Add user “nandha” to sudoers list.

  • Dhurjati

    thanks…its working without any problem

  • Filipino J.

    thanks…

  • Akshay

    After updating rpmfusion-free-release-stable.noarch.rpm

    When I am using sudo yum install vlc

    I am getting this message :

    Loaded plugins: langpacks, presto, refresh-packagekit
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-15&arch=i386 error was
    14: HTTP Error 404 – Not Found : http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-15&arch=i386
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-15&arch=i386 error was

    Please tell what is the problem with my configuration how can I resolve It

    thanks,
    Akshay

  • Kaushal Anand

    Thank you very much..This is really helpful i solved my problem on. Fedora Core 16.

    Intel i5 processor.

    Thanks .

  • Aswin

    When I am trying it says “bash: $: command not found”
    What to do??

    • http://www.howopensource.com Manivannan

      Hi Aswin,

      Copy the command alone, Avoid “$” while copying.

  • sunil

    Throwing error in terminal saying transfer failed. Alternative tried SU command in terminal says incorrect password.

  • harry

    hey, after installing vlc on fedora 16, sound is gone from my system. please help

  • rony

    i am working on fedora 16 but not able to install any player

  • ajay

    warning: /var/tmp/rpm-tmp.lL9IQn: Header V3 RSA/SHA256 signature: NOKEY, key ID 865cc9ea
    error: Failed dependencies:
    system-release >= 14 is needed by rpmfusion-free-release-14-2.noarch

  • thanu

    It was very easy and simple. The whole process took less than 5 minutes! Thanks a lot!!

  • pgray

    Perfect!

    Most of the errors mentioned in the above comments are not VLC or yum’s fault…

  • Antonio

    Thank you, Manivannan. It’s worked in Fedora 17 Beta too. People like you make the Internet better.

  • Phendrome

    Worked perfectly well on Fedora 17 Beta with Xfce.

    This guide makes you install the latest stable version.

  • devendra

    system-release >= 15 is needed by rpmfusion-free-release-15-5.noarch

    m not able intall vlc in fedora 11…….plzzz help

  • Abdul Kadir

    This link is not working with fedora 14. it’s work with fedora 15, 16. 17 not with fedora 14.

    plz update your link as well as fedora 14 too…..

    Regards
    Abdul

    • http://www.howopensource.com Manivannan

      Thanks for the info Abdul, I will Update it.

  • Pingback: download audacity free

  • Jaisingh T

    When I tried to install vlc on fedora 14 this is message I am getting.

    error: Failed dependencies:
    system-release >= 15 is needed by rpmfusion-free-release-15-5.noarch

    can any one help me please?

  • akash

    this vlc does not working in my fedora 16

    • http://www.howopensource.com Manivannan

      Hi akash,

      your using 64bit or 32bit?

  • prakash

    When I tried to install vlc on fedora 14 this is message I am getting.

    error: Failed dependencies:
    system-release >= 15 is needed by rpmfusion-free-release-15-5.noarch

    can any one help me please?

    • HowOpenSource

      I have updated the content, Now it will work for you :)

  • Krish

    Thank you buddy, Installation went like a breeze on my netbook (Fedora 16 with lxde).
    Krish

  • Asr

    Where is the setup file , if I want to install again then Will I have to download It again

  • dipen

    thanks buddy i install vlc on my fedora 16 thankyou very much

  • izoma2

    prakash,Jaisingh T

    download the following three rpm packages from the link given below and install them manualy

    x264-0.0.0-0.28.20100706gitd058f37.fc14.i686.rpm
    x264-libs-0.0.0-0.28.20100706gitd058f37.fc14.i686.rpm
    libva-freeworld-0.31.1-1.sds4.fc14.i686.rpm

    after installation go to APPLICATION>system tool>terminal
    in terminal type commands one by one if there is an error neglect it .

    su -
    rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
    yum install vlc

    http://rpm.pbone.net/index.php3/stat/4/idpl/17910094/dir/fedora_14/com/x264-libs-0.0.0-0.28.20100706gitd058f37.fc14.i686.rpm.html

  • Chercher l’expert

    Very usefull.
    Thanks.

  • chantiya

    i got this error when i wrote to my termi[root@chantiya chantiya]# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
    Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
    curl: (7) couldn’t connect to host
    error: skipping http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm – transfer failed
    [root@chantiya chantiya]#

  • http://www.mozilla.com Srinivas

    guys why you use window’s ,,,use fedora os ,,excellent user interface

  • rambo

    thanks yr….

  • Sved

    Thank you, works fine!

  • sudhanshu

    I want to install VLC on my Fedora-15.

    Following steps executed successfully:
    $> su -
    #> rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm

    But while installing VLC I get following error messages:
    =========================================================================
    [root@Sudhanshu sshukla]# yum install vlc
    Loaded plugins: langpacks, presto, refresh-packagekit
    http://download.fedoraproject.org/pub/fedora/linux/releases/15/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 500 – Internal Server Error : http://download.fedoraproject.org/pub/fedora/linux/releases/15/Everything/i386/os/repodata/repomd.xml
    Trying other mirror.
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-15&arch=i386 error was
    14: HTTP Error 500 – Internal Server Error : http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-15&arch=i386
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-15&arch=i386 error was
    14: HTTP Error 500 – Internal Server Error : http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-updates-released-15&arch=i386
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-15&arch=i386 error was
    14: HTTP Error 500 – Internal Server Error : http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-15&arch=i386
    Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-15&arch=i386 error was
    14: HTTP Error 500 – Internal Server Error : http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-15&arch=i386
    http://download.fedoraproject.org/pub/fedora/linux/updates/15/i386/repodata/repomd.xml: [Errno 14] HTTP Error 500 – Internal Server Error : http://download.fedoraproject.org/pub/fedora/linux/updates/15/i386/repodata/repomd.xml
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmfusion-free. Please verify its path and try again
    [root@Sudhanshu sshukla]#
    =========================================================================

    Any suggestions for this issue ?

    Regards,
    SS

  • http://www.howopensource.com ashutoshh singh

    this is really worked thanks …a millions

  • Iran Illukkumbura

    It’s working… thank you so much!!!

  • frei

    thanks it s works

  • Rajith Marl

    thanks

  • http://www.facebook.com/gediegid Gathekia Kariuki

    Thanks alot…..

  • Oliver

    Thanks a lot

  • r0x

    SPL THX

  • cerka

    Million thanx, God bless!

  • Michel

    works fine ! thx!

  • octopus-beta

    Thank you!

  • Ankeet Anand

    i cant install..it says refresh packagekit

  • sunny

    will i get this in fedora 19

  • tzioneretz

    What a piece of shit operating system… Both Windows and Mac O.S. allow a user to install a simple application in a straightforward process, quickly and with minimal fuss. Linux, however, insists on all this rigmarole. And even then, as other people’s comments here suggest, something is bound to go wrong. I’ll stick to Windows, gracias very much.

    • Matt

      I’m sorry, but your comment is totally wrong.

      Whether an application is easy to download and install depends on the application and its packaging, not on the operating system. Just as there are many applications that are easier to install on Windows and Mac than on Fedora, there are also many applications that are easier to install on Fedora than on Mac or Windows.

      In other words, your issue is with VLC, not with Fedora.

      • tzioneretz

        Aha. Can you, then, please tell me how to set the Delete button to — guess what — DELETE the selected file(s) in Fedora 19? The answer should be something that is doable in 5-10 seconds. While at it, perchance you could enlighten me as to why that is not the default action in Fedora anyway, as it is one of the most intuitive things in the world.

        Look, I’ve been using Linux for year and have some very fond memories of spending nights doing programming for my degree courses. But let’s be honest here: On usability, Windows wipes the floor with Unix.

    • LMAO

      Yes you are right. Those fools use Linux on their servers, mainframes and even supercomputers. Please give them some of the wisdom you own. We really need people like you.

  • tharan

    i have installed it but the video is not opening

  • Pn Vu

    I followed your steps and got it. Thanks :) Love VLC player. I still use it in Windows 7 and now on Fedora 20

  • BG

    on Fedora 19:

    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libgcrypt.so.20()(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libass.so.5()(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: liblua-5.2.so()(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libgcrypt.so.20(GCRYPT_1.6)(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libpng16.so.16()(64bit)
    Error: Package: ffmpeg-libs-2.2.2-1.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libass.so.5()(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libva.so.1(VA_API_0.33.0)(64bit)
    Error: Package: vlc-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
    Error: Package: vlc-core-2.1.4-5.fc21.x86_64 (rpmfusion-free-rawhide)
    Requires: libpng16.so.16(PNG16_0)(64bit)