Unable to install Google Chrome dependency error libnss3-1d / libxss1 in Ubuntu 13.04 / 12.10 / 12.04

While installing google chrome stable from debian package, you might face dependency error. To avoid this dependency error, Install Google Chrome in Ubuntu using PPA

“”” dpkg: dependency problems prevent configuration of google-chrome-stable:

google-chrome-stable depends on libnss3-1d (>= 3.12.3); however:

and

google-chrome-stable depends on libxss1; however:

dpkg: error processing google-chrome-stable (–install): “””

Check the screen shot below.

To Solve

Install the dependency libraries by using the following commands on terminal, type the password for the user when prompted.

NOTE: To avoid mistakes copy and paste the commands in terminal, because “l” is looks like “1” in below commands.

For libnss3-1d

sudo apt-get install libnss3-1d:i386

For libxss1

sudo apt-get install libxss1:i386

After installing the dependencies try re-installing the google chrome stable. It will work.

Hope this will be helpful for you!!!

Related Posts Plugin for WordPress, Blogger...

  • Pingback: Install Google Chrome in Ubuntu 12.04 using .deb file | HowOpenSource()

  • ambrose

    not working for me pls help its showing the following errors
    for libnss3-1d / libxss1 in Ubuntu 12.04
    ambrose@ambrose-System-Product-Name:~/Downloads$ sudo apt-get install libnss3-1d:i386
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt-get -f install’ to correct these:
    The following packages have unmet dependencies:
    google-chrome-stable : Depends: libxss1 but it is not going to be installed
    E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
    —————————————————————-
    ambrose@ambrose-System-Product-Name:~/Downloads$ sudo apt-get install libxss1:i386
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt-get -f install’ to correct these:
    The following packages have unmet dependencies:
    google-chrome-stable : Depends: libnss3-1d (>= 3.12.3) but it is not going to be installed
    E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

  • James

    @ambrose
    Open Terminal and run sudo apt-get -f install

    After that just install Chrome as a standard .deb file.

    Hope all works! :)

  • Deepa

    it isnt working!

    deepa@deepa-desktop:~/Downloads$ sudo apt-get install libxss1:i386
    Reading package lists… Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/extras.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
    E: The package lists or status file could not be parsed or opened.
    deepa@deepa-desktop:~/Downloads$
    please help!

    • Manivannan M

      Try below commands first and try installing it again

      sudo rm /var/lib/apt/lists/* -vf

      sudo apt-get clean

      sudo apt-get update

  • I’ve downloaded chrome but installation is becoming a problem. I am receiving the following error
    and really messing up with me. Any help is kindly welcome. Thx

    eng-yoas@kali:~/Downloads$ sudo dpkg -i google-chrome-stable_current_x86_64.rpm
    dpkg-deb: error: ‘google-chrome-stable_current_x86_64.rpm’ is not a debian format archive
    dpkg: error processing archive google-chrome-stable_current_x86_64.rpm (–install):
    subprocess dpkg-deb –control returned error exit status 2
    Errors were encountered while processing:
    google-chrome-stable_current_x86_64.rpm